ERROR 1819 (HY000): Password does not satisfy the current policy requirements

Вопрос

При установке phpMyAdmin возникает ошибка: ERROR 1819 (HY000): Password does not satisfy the current policy requirements, как это исправить? Версия MySQL 8.0.30

Ответ

В случае возникновения ошибки ERROR 1819 (HY00), выберите пункт ignore:

Настройка конфигурации phpMyAdmin в случае ошибки ERROR 1819 (HY00)

Выполните одну из этих процедур для решения проблемы:

Измените политику паролей

Если ваша политика паролей установлена на уровне MEDIUM или STRONG, измените это значение на LOW, для этого выполните:

SET GLOBAL validate_password.policy=LOW;

Удалите модуль проверки пароля

Подключитесь к серверу под логином root и удалите плагин:

UNINSTALL PLUGIN validate_password;

После успешной настройки конфигурации phpMyAdmin восстановите прежние настройки.